[삽질중] react-native steem 연동

발생한 문제

steem js 라이브러리를 react-native에서 사용하려고 하니

에러가 발생했다.

이를 해결하기 위한 방법들이다.

anpigon님이 잘 해결을 해주셨다.

https://busy.org/@anpigon/react-native-steemjs–1546529527678/


해결함.

anpigon님이 작성한 튜토리얼대로 진행했다. 그대로해도 에러가 났는데

base-x가 문제였다. 이 버젼을 3.0.4로 바꿔서 해결하였다.


base-x 버젼 체크를 해보니 3.0.5로 돼있다.

npm view base-x version

base-x의 버젼을 3.0.4로 바꾼다.

npm install base-x@3.0.4

error로  아래같은 에러가 발생했다. 그래서 async도 다시 설치해봤다.

npm ERR! peer dep missing: asyncstorage-down@>=3.0.0 <5.0.0, required by react-native-level-fs@3.0.1
│ │ └─┬ base-x@3.0.5

npm install asyncstorage-down


history

2019 npm install
2020 react-native run-android
2021 npm list
2022 npm list |grep base-x
2023 npm view base-x version
2024 npm install base-x@3.0.4
2026 npm install asyncstorage-down
2030 npm install
2031 react-native run-android


참고한 링크들

https://github.com/steemit/steem-js/issues/190

https://github.com/steemit/steem-js/issues/196

https://busy.org/@anpigon/react-native-steemjs–1546529527678/

https://github.com/Insteem/insteem-app_bak/tree/master/insteem

 

댓글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다